Data Missing when using CacheTables

Questions and Answers asked by users to users, about how others use Jet Reports.

For additional "how to" information, please visit our online Knowledge Base ... ofessional
Forum rules
The Jet Reports Community forums are not a guaranteed support medium. Official support for Jet Reports is available only through the support desk at Staff responses to posts on the forum are not guaranteed.
Posts: 2
Joined: Tue Jun 02, 2015 7:54 am

Data Missing when using CacheTables

Postby GWNYC » Thu Sep 17, 2015 10:51 am

I have a large spreadsheet that summarizes employee benefits by pay control for a given date range. It uses 31 NL sum functions for the benefits, and one NL rows function to populate employees (plus a few minor nl functions for demographic data). When we were running Nav 5 and Jet 9, the report ran in about 5 minutes. Now that we upgraded to Nav 2013R2 and Jet 2015U1, it takes 6 hours.

Upon our conversion testing, we found that many of our spreadsheets would take hours to run instead of minutes, and the solution given to me back then was to add CacheTables to the A1 cell. This has worked for many spreadsheets, and they run fine.

This particular spreadsheet, which went from 5 minutes to about 6 hours or so is not behaving the same way. Adding the CacheTables function worked to speed it up, as it now takes about 3 minutes, but unfortunately, the report is missing most of the data. A few of the early columns populate, but the majority of them do not, and are either completely empty or mostly empty, actually they are not empty, but show as 0. Interesting enough, when I drill down, the drill down window does show the correct entries and has amounts in them.

I refreshed and re-ran, but the same thing. I made the columns absolute reference instead of dynamic. I tried everything I could, but nothing helped. With the CacheTables, the report is missing most of the data. Without the CacheTables, it runs with the correct values, but takes forever.

How do I get this sheet to run properly within a normal time frame?

Thank you,


User avatar
Jet Reports Certified Professional
Posts: 441
Joined: Wed May 26, 2010 3:40 pm

Re: Data Missing when using CacheTables

Postby HPDeskJet » Thu Sep 17, 2015 1:24 pm

Hello Lewis -

While this would probably be a great question to run by Jet's support team, if your report does not contain any confidential information when it is in Design mode, I'd be happy to take a look at it.

Otherwise, submitting a private support ticket would be your best option - as it would be difficult to try to troubleshoot without examining the report itself.
Jet 2015 Certified Trainer

Posts: 2
Joined: Tue Jun 02, 2015 7:54 am

Re: Data Missing when using CacheTables

Postby GWNYC » Thu Sep 17, 2015 1:57 pm

Thanks. I'll do that.

Return to “How do I?”

Who is online

Users browsing this forum: No registered users and 3 guests