Excel issues (losing formatting randomly on save)

Put your best Excel related tips and tricks here.
Forum rules
This is the place to put all of your Excel Tips & Tricks.
badjesus
Posts: 2
Joined: Thu Dec 08, 2016 11:39 am

Excel issues (losing formatting randomly on save)

Postby badjesus » Thu Dec 08, 2016 3:12 pm

Hey everyone.

So basically, we just upgraded our NAV and our office/jet. There is a report, it is a sales report, that we use for the whole company. Probably the most important report that we have.
We have been using office 2007 and NAV5 DB for the longest time without issue. Since the upgrade, everything has gone to c**p.

The file was originally a 2003 compatible excel document. We upgraded it to a current document, .xlsm for office 2016.

The report used to take 45 minutes to run in JET. It now takes 2 1/2 hours. To help this, we set up a new table with a lot less data. We haven't tested it's speed here yet but hope to in the next few days.

The biggest issue though, is randomly when we run the file and save it, we lose all formatting on the same column. For the most part, it is any date field that is being populated. When we run JET, everything looks fine. When we save the file, it is corrupted on these same fields. There is nothing special about the fields, they are just set as DATE. SOme only show the year, some calculate the number of days. Another column that gets messed up is a RANK formula. It is just formatted as general. When we open the file back up after saving it, randomly (about every 4th time) it shows ##### instead of the rank. When we change the Formatting to a number, everything shows up properly again.

I looked online, and found a few other people who have had this issue with Excel on technet. None of the posts have any resolution.

One person did post a link to a now dead URL and mentioned it has something to do with saved styles. A bit more research led to a few issues when there are too many saved styles. The suggestion is to delete those styles. As they aren't needed on the report, I tried to delete them. However; I can't delete them.

The page, and the workbook are both UNPROTECTED under the review tab. However; when I try to delete the styles, it says I can't because the Sheet is protected. It isn't protected.

It seems to be nothing but issues ever since upgrading. The worst part is, this is just random. We will do multiple reports without issue and them bam..... messed up formatting.

What is so strange, is that it isn't just like a corrupt file. The same fields lose their formatting every time. We save as the same format every time.

User avatar
HPDeskJet
Jet Reports Certified Professional
Posts: 443
Joined: Wed May 26, 2010 3:40 pm

Re: Excel issues (losing formatting randomly on save)

Postby HPDeskJet » Fri Dec 09, 2016 8:35 am

This is something that you will definitely want to work out with Jet Reports Technical Support (https://support.jetreports.com).
-HP
_______________________
Jet 2015 Certified Trainer

badjesus
Posts: 2
Joined: Thu Dec 08, 2016 11:39 am

Re: Excel issues (losing formatting randomly...

Postby badjesus » Fri Dec 09, 2016 9:26 am

I did.... It was NOT very helpful so far. :)

When you do a ticket with them, you have to answer questions. Such as; it asks if you are using webservices or if not, what type of connection.

Their response to me, despite me stating in the ticket that I am NOT using webservices in 2 different spots, was to stop using webservices.

The persons reply is hard to decipher, full of grammar and spelling mistakes, and appeared as though they didn't even read my ticket.


Return to “Excel Tips & Tricks”

Who is online

Users browsing this forum: No registered users and 1 guest